Software

/Software
Software2019-01-22T14:34:28+00:00

BASISSTATION

Die Basisstation hat eie Anzeige montiert, welche den momentanen Status (z.B. Wlan-Verbindung aktiv) anzeigt. Zusätzlich muss ein Router angeschlossen sein, welcher einen WLAN Hotspot erzeugt, mit dem sich die Smartphones verbinden können.

Basisstation mit Raspberry Pi, Router, Powerbank

APP

Zur Verwendung von Phasertag Mobile ist die Installation der Phamobi-App notwendig. Jeder Mitspieler benötigt ein funktionstüchtiges Android Smartphone (Mindestanforderung Android Version 5.0) mit der installierten App. Um mit der App und der Hardware zu interagieren, benötigt das Smartphone einen Touchscreen sowie Bluetooth und Wlan Funktion. Die App muss während des Spiels geöffnet und aktiv sein.

AppLauncher

App Screens

Der Spieler wird durch die Spielerstellung geführt. Pro Spiel gibt es einen Master, der die Einstellungen vornehmen und Spieler hinzufügen kann. Andere Member treten lediglich dem Spiel bei und warten bis es gestartet wird.
Während des Spiels werden alle Spieler über den derzeitigen Spielstand, verbleibende Zeit sowie eigene und gegnerische Treffer informiert.

App Start Screen

Start

Bluetooth-Verbindung zur Basisstion aufbauen. Danach kann mit der Einrichtung bzw. dem Beitreten des Spiels fortgesetzt werden.

App Start Game

Spiel erstellen/beitreten

Individuellen Spielernamen eingeben. Dann entweder einem existierenden Spiel beitreten oder als Master ein neues Spiel erstellen.

App Select Gamemode

Spielmodus

Spielmodus auswählen. Derzeit nur Team Mode möglich.
dfgkjdaflgj
sdsdsd<\span>

App Teamzuteilung

Teamauswahl

Teams zusammenstellen. Verfügbare Mitspieler den Teams zuordnen.
dfgkjdaflgj

App SetLimits

Limits

Limits für Zeit, Treffer und Munition setzen.
dfgkjdaflgj
sdsdsd<\span>

Spielstand

Spielstatus

Anzeige der aktuellen Spielinformationen. Möglichkeit zum Pausieren und Spiel Beenden durch Master möglich.

SCHNITTSTELLEN

  • Die Basisstation benötigt eine Java Runtime Environment der Version 1.7 (Java 7 JRE) oder höher.

  • Die App verwendet die Android-Systembibliothek und erfordert eine Android Version von 5.0 (API Level 21) oder höher.